[Rumor] PS4 games sent to certificate after 13th July must run on PS5

On June 4 we could see the first games running on PS5. Next gen is almost here, but a new gen does not mean that we cut everything with the former generation.

Eurgamer publish that PS4 games send to certification after 13th July must be compatible on PS5. Therefore, all the PS4 launched after that point should be fully compatible with PS5 when the system will be available.

Sony forces developers to do their PS4 games compatible and they strongly recommend to do the same with existing games. Sony has uploaded this info in their internal partner website for PlayStation developers.

Thanks, Eurogamer.